Mach-E Forum | Ford Mustang Mach-E Forum and News banner
21 - 34 of 34 Posts

·
Super Moderator
Joined
·
3,032 Posts
When I picked up my FE on 2/13 Wilson Ford in Corvallis applied a license fee of: $876.50, Title Fee: $187.00, Title & Reg Processing Fee: $115.00, Privilege Tax: $294.40, CAT Tax: $217.85. So a total of $1690.75. Since I got my X-Plan discount, the total cash sales price was $58879.00 and with the add-ons above: $60569.75.

The problem is when I got it home I realized there was no credit give for the $1000 downpayment I put down last June. The dealer it trying to get this figured out with Ford - I have yet to get a refund check for this... Not great.

Also my FE is now back at the dealer at the shop. Yesterday it started displaying Drive Train power errors on the instrument cluster screen, and my FordPass App delivered a diagnostic message copied below. I also got a collision avoidance system failure while driving it yesterday. Yesterday I was at the dealer picking up some floor mats I'd ordered and they checked the OBD port and there were no codes showing. I got the FordPass diagnostic (copied below) after I got back from the dealer. This morning it was fine again but I checked it in to the service department for them to go over it. I've seen on the Macheclub.com forum that a fair number of MME owners are reporting this same error and are not getting a resolution from Ford about it yet - although Ford di send an engineer out to an owner not far from Dearborn, and he loaded updated firmware to control some basic system functions - apparently not something that is done over the air. As of last night it wasn't clear if this solved the problem.

I've only driven a couple of hundred miles thus far - so this is disappointing to say the least.
View attachment 4491
Hopefully it is related to the known fix, fingers crossed.

Make sure to speak with the manager when you go back. You should be able to walk out with a check in hand for the missing $1,000 deposit.
 

·
Registered
Joined
·
21 Posts
Just talked to the service department. While they've had the car for the entire day they haven't actually looked at it yet. Not good. I dropped it off at 8:30 am and it is now 4:30 pm. Since I had them on the line I had them pull some diagnostics they were able to get online that I don't have access to. It indicated there was a communication failure between a number of subsystems related to the drivetrain and to the front camera (which could also explain why my collision avoidance system bugged out yesterday). I'm waiting for a callback for more info now that they are finally plugging a scanner into the car. So not a great response from the dealer's service department and a pretty sobering bit of information about the significant problems in basic subsystem reliability. I expected some glitches but this is rapidly becoming worst-case. If I had to do it all over again, I don't think I'd proceed with the purchase of a MME at this time. Maybe in a year. I always thought I'd end up being a beta tester being an early adopter, but this feels more like being an alpha tester. For $60k no less. For a car that is rapidly depreciating and that I can't drive. For a FE that I paid $3,700 more for than an identically equipped non-FE Premium extended range AWD that was released ahead of the FE. Caveat emptor.
 

·
Registered
Joined
·
385 Posts
've only driven a couple of hundred miles thus far - so this is disappointing to say the least.
No effing kidding!!!! Bumpy startup for MachE in some parts. Ford better hope that the one AlexOnAutos purchased does not have any issues or the EV mediaverse will explode and the Tesla vultures will be circling.
 

·
Registered
Joined
·
21 Posts
No effing kidding!!!! Bumpy startup for MachE in some parts. Ford better hope that the one AlexOnAutos purchased does not have any issues or the EV mediaverse will explode and the Tesla vultures will be circling.
One can only hope for a loud noise to start circulating on the twitterverse.

I've retrieved my FE from the dealer. The latest news from Ford corporate is they know about this issue and have a software fix. And it will released in.... May!

Until then they say it is safe to drive.

My dealer says if errors pop up again to contact them so they can track the diagnostics and they'll tell me if its the same or a different issue.

So basically I'm flying blind not being able to trust any fault conditions are real or not - at least until May. Why if that not reassuring?

How frequently does Tesla release incremental SW updates? And the best Ford can do is May when it is now February.
 

·
Registered
Joined
·
12 Posts
Sorry for your hassles... regarding the deposit, I forgot about it until I had driven away. My rep called me the next day and said they will send me a check for the $500 deposit, so I expect to see it in a few days. I had a Tesla 3 which had a number of fit and finish issues, but technologically speaking, it was flawless. It was a bit more quirky in design, but everything worked... If my Mach e becomes a disappointment (which it is not at the moment), I'll probably get a Y. Good luck!
 

·
Registered
Joined
·
21 Posts
Sorry for your hassles... regarding the deposit, I forgot about it until I had driven away. My rep called me the next day and said they will send me a check for the $500 deposit, so I expect to see it in a few days. I had a Tesla 3 which had a number of fit and finish issues, but technologically speaking, it was flawless. It was a bit more quirky in design, but everything worked... If my Mach e becomes a disappointment (which it is not at the moment), I'll probably get a Y. Good luck!
Glad they called you about the deposit - but wasn't it $1000 and not $500? It was $500 to reserve a spot to make a reservation, then that should have been refunded directly by Ford when you deposited $1000 when your order was accepted.
 

·
Registered
Joined
·
12 Posts
Glad they called you about the deposit - but wasn't it $1000 and not $500? It was $500 to reserve a spot to make a reservation, then that should have been refunded directly by Ford when you deposited $1000 when your order was accepted.
No, the $500 reserve was refunded back in May or June, and at that time the deposit request to me was $500, not $1000.
 

·
Registered
Joined
·
12 Posts
BTW, I have a black GT on $500 reserve, no request for deposit as yet as orders will start around April. I'm not going to convert to an order, so I will likely just let it go (and get the $500 back). If anyone wants my place in line and if they permit that, it's fine with me.
 

·
Registered
2021 Ford Mustang Mach-e FE Grabber Blue
Joined
·
7 Posts
I'm in Beaverton with a Grabber Blue First Edition. Someone told me they saw another GB in Hillsboro, but I haven't seen any others of any color on the road yet.
 

·
Registered
Joined
·
1 Posts
Has anyone had any dealings with Landmark Ford? I ordered on 4/23. No build date or anything as of yet. They seem pretty nice there, but I'm not sure they're fully up to speed on the Mach E yet. They don't deduct the Oregon EV Rebate at point of sale, just FYI.
 

·
Registered
Joined
·
12 Posts
Has anyone had any dealings with Landmark Ford? I ordered on 4/23. No build date or anything as of yet. They seem pretty nice there, but I'm not sure they're fully up to speed on the Mach E yet. They don't deduct the Oregon EV Rebate at point of sale, just FYI.
I have a black GT reserved at Landmark, but not ordered as yet. I probably will let that go as I took delivery of an FE in mid Feb. Landmark seemed perfectly pleasant, the red FE was ordered at Damerow, which also was easy to deal with. I got my OR $2500 rebate in the mail within a month of delivery, so it's not a big deal either way. I'll probably go in to Landmark in the next week or so and cancel and get my $500 deposit back. If anyone out there wants my place in line, I'm sure that can be arranged.
 

·
Registered
Joined
·
23 Posts
Has anyone had any dealings with Landmark Ford? I ordered on 4/23. No build date or anything as of yet. They seem pretty nice there, but I'm not sure they're fully up to speed on the Mach E yet. They don't deduct the Oregon EV Rebate at point of sale, just FYI.
I ordered my premium MME through Landmark. They didn't impress me with their knowledge of the car's systems and software, but then again it was very early and maybe they've had some time to learn.
The car had a couple of minor dents and scratches, probably a delivery issue. Make sure to inspect it carefully.
Landmark ordered the parts, then drove to my house to bring the car in. A week or so later they drove it back to me with everything repaired to new condition.
 
21 - 34 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top