Mach-E Forum | Ford Mustang Mach-E Forum and News banner
1 - 19 of 19 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I had to bring my mache into the dealership yesterday for the bluecruise software update. I just picked the car up, and there’s nobody here who knows anything about it. The techs are gone . I don’t see anything new for bluecruise in the settings . How do I activate ? Thanks!
 

·
Premium Member
2021 Star White RWD/ER Premium
Joined
·
3,116 Posts
I had to bring my mache into the dealership yesterday for the bluecruise software update. I just picked the car up, and there’s nobody here who knows anything about it. The techs are gone . I don’t see anything new for bluecruise in the settings . How do I activate ? Thanks!
Be 'The EV Guy' posted a video on your question. Also, check your 'connected services' to see if you have a termination date for the free year.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Be 'The EV Guy' posted a video on your question. Also, check your 'connected services' to see if you have a termination date for the free year.
Thanks for the response. I’ll look for the video. Under Connected services , it shows “coming soon “ above BlueCruise.., frustrating
 

·
Registered
2021 ME FE Grabber Blue
Joined
·
376 Posts
I found Ben the EV guy Blue Cruise video and it did not Help with my problem
If it installed correctly Ford will enable Blue Cruise. Doesn’t happen immediately. You should get a notification in Ford Pass once it’s enabled. Mine took 24 hours after the last OTA.
 

·
Premium Member
2021 Star White RWD/ER Premium
Joined
·
3,116 Posts
If it installed correctly Ford will enable Blue Cruise. Doesn’t happen immediately. You should get a notification in Ford Pass once it’s enabled. Mine took 24 hours after the last OTA.
Thanks, just picked up the MMe and it states 'BlueCruise activated ' when I push the cruise button, but I still have to hands on to drive. I'll wait for the Manage services notification
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #7 ·
Thanks, just picked up the MMe and it states 'BlueCruise activated ' when I push the cruise button, but I still have to hands on to drive. I'll wait for the Manage services notification
Blue-cruise
If it installed correctly Ford will enable Blue Cruise. Doesn’t happen immediately. You should get a notification in Ford Pass once it’s enabled. Mine took 24 hours after the last OTA.
It’s been >2days after the update and it’s still not activated .
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #10 ·
The lane assist is worse now .. maybe another dealership will install the software .. what a waste of time
One dealer installed and another checked and said the updates were installed correctly, and I still don’t have blu cruise and the assisted driving is worse . Makes no sense ..
 

·
Registered
Joined
·
11 Posts
I'll put my 2 cents in here.

I took ours into the dealer for the 10,000 mi service and had them install the BC update. My dealer has one tech who does the EVs and, gods love him, he's doing the best he can but Ford training and information flow is about as useless INSIDE Ford as it is OUTSIDE. The update instructions he got were incomplete. He found relevant updates in 3 places - the main Ford database (Equinox? not sure what it's called), one he had to upload to a USB drive and install through the car's USB, and one he found on another database by accident because he just thought he'd try his luck and see if there was anything there. This last one turned out to be the kingpin that finally brought everything together and activated BC.

All in, it took 3 days plus a morning. One update crashed 3 times, another one took 7 hours by itself. The tech contacted Ford Engineering when he was having a problem with the updates and Ford responded that they're inundated with calls from all over the country for the same problem doing dealer updates, that they're working on a solution, and "don't call us, we'll call you" when they have a solution.

The only indication that BC is now installed is that the "Lane Centering" item in "Adaptive Cruise Control" now reads as "Lane Centering with Hands Free", which is as per the Ford tech instructions.

We haven't had a chance to test it yet but I should be able to this weekend.

On a side note, the BC box on my FordSupport account "Connected Services" page, which mysteriously appeared a month ago when other saw theirs, just as mysteriously disappeared while the update was happening. So now, I'm not entirely sure what's going on.

More to follow as the story unfolds.
 

·
Premium Member
2021 Star White RWD/ER Premium
Joined
·
3,116 Posts
I'll put my 2 cents in here.

I took ours into the dealer for the 10,000 mi service and had them install the BC update. My dealer has one tech who does the EVs and, gods love him, he's doing the best he can but Ford training and information flow is about as useless INSIDE Ford as it is OUTSIDE. The update instructions he got were incomplete. He found relevant updates in 3 places - the main Ford database (Equinox? not sure what it's called), one he had to upload to a USB drive and install through the car's USB, and one he found on another database by accident because he just thought he'd try his luck and see if there was anything there. This last one turned out to be the kingpin that finally brought everything together and activated BC.

All in, it took 3 days plus a morning. One update crashed 3 times, another one took 7 hours by itself. The tech contacted Ford Engineering when he was having a problem with the updates and Ford responded that they're inundated with calls from all over the country for the same problem doing dealer updates, that they're working on a solution, and "don't call us, we'll call you" when they have a solution.

The only indication that BC is now installed is that the "Lane Centering" item in "Adaptive Cruise Control" now reads as "Lane Centering with Hands Free", which is as per the Ford tech instructions.

We haven't had a chance to test it yet but I should be able to this weekend.

On a side note, the BC box on my FordSupport account "Connected Services" page, which mysteriously appeared a month ago when other saw theirs, just as mysteriously disappeared while the update was happening. So now, I'm not entirely sure what's going on.

More to follow as the story unfolds.
Just returned from an 800mile round trip. The BC updates that I had the dealer load last week apparently were incomplete. When I push the 'cruise button' it states "Blue Cruise Active" when I look away from the road I receive a "pay attention" warning however, I am not able to drive hands free. Best guess one or more modules didn't load properly.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #13 ·
Just returned from an 800mile round trip. The BC updates that I had the dealer load last week apparently were incomplete. When I push the 'cruise button' it states "Blue Cruise Active" when I look away from the road I receive a "pay attention" warning however, I am not able to drive hands free. Best guess one or more modules didn't load properly.
Just returned from an 800mile round trip. The BC updates that I had the dealer load last week apparently were incomplete. When I push the 'cruise button' it states "Blue Cruise Active" when I look away from the road I receive a "pay attention" warning however, I am not able to drive hands free. Best guess one or more modules didn't load properly.
I'll put my 2 cents in here.

I took ours into the dealer for the 10,000 mi service and had them install the BC update. My dealer has one tech who does the EVs and, gods love him, he's doing the best he can but Ford training and information flow is about as useless INSIDE Ford as it is OUTSIDE. The update instructions he got were incomplete. He found relevant updates in 3 places - the main Ford database (Equinox? not sure what it's called), one he had to upload to a USB drive and install through the car's USB, and one he found on another database by accident because he just thought he'd try his luck and see if there was anything there. This last one turned out to be the kingpin that finally brought everything together and activated BC.

All in, it took 3 days plus a morning. One update crashed 3 times, another one took 7 hours by itself. The tech contacted Ford Engineering when he was having a problem with the updates and Ford responded that they're inundated with calls from all over the country for the same problem doing dealer updates, that they're working on a solution, and "don't call us, we'll call you" when they have a solution.

The only indication that BC is now installed is that the "Lane Centering" item in "Adaptive Cruise Control" now reads as "Lane Centering with Hands Free", which is as per the Ford tech instructions.

We haven't had a chance to test it yet but I should be able to this weekend.

On a side note, the BC box on my FordSupport account "Connected Services" page, which mysteriously appeared a month ago when other saw theirs, just as mysteriously disappeared while the update was happening. So now, I'm not entirely sure what's going on.

More to follow as the story unfolds.
That makes sense because the ford dealership techs don’t seem to really know . I think they atefoinmg their best . .. btw, after the last update, the blue lane assist bubble disappeared and Lane assist is not as good as before .
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #14 ·
That makes sense because the ford dealership techs don’t seem to really know . I think they are doing their best . .. btw, after the last update, the blue lane assist bubble disappeared and Lane centering assist is not as well as before .

Ford should not have advertised blue cruise because it’s caused so much confusion and disappointment.
 

·
Registered
Joined
·
59 Posts
Wow, I have an appointment to get my car into dealership for the BC update. Now I am thinking it might not be worth it. Might as well wait for a while until they figure out these issues. I did get the 2.6.0 update the other day and an email from Ford saying Blue Cruise is coming as sevel OTA updates. Maybe I will get it eventually, a year late already another Month or two is no big deal !!!
 

·
Registered
Joined
·
11 Posts
With hindsight, I wouldn't have bothered with the dealer install and would just let the OTA update happen whenever it happens. I only did it because the car was in for service anyway and it seemed like a convenient opportunity.

In reality, BC is a nice feature, but it's not a fundamental game changer. I think I've become obsessed with it and over-zealous to activate it when, really, it's not worth the time and emotional effort I've put into it.

My advice? Cancel the dealer install and let it happen OTA as and when.
 

·
Registered
2021 ME FE Grabber Blue
Joined
·
376 Posts
Wow, I have an appointment to get my car into dealership for the BC update. Now I am thinking it might not be worth it. Might as well wait for a while until they figure out these issues. I did get the 2.6.0 update the other day and an email from Ford saying Blue Cruise is coming as sevel OTA updates. Maybe I will get it eventually, a year late already another Month or two is no big deal !!!
Wise decision. My BlueCruise was enabled in April via OTA updates. Dealer success is hit and miss. You could be without a vehicle for any amount of time. Worst case they brick it.
 

·
Registered
Joined
·
11 Posts
Yeah, we were without the car for 3 days (5 if you count the weekend the dealer didn't work on it, but we were out of town so it didn't matter) and, 2 days later, I'm still messing around with Ford.

Fortunately, we also have a '65 Mustang, so we weren't too inconvenienced.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #19 ·
With hindsight, I wouldn't have bothered with the dealer install and would just let the OTA update happen whenever it happens. I only did it because the car was in for service anyway and it seemed like a convenient opportunity.

In reality, BC is a nice feature, but it's not a fundamental game changer. I think I've become obsessed with it and over-zealous to activate it when, really, it's not worth the time and emotional effort I've put into it.

My advice? Cancel the dealer install and let it happen OTA as and when.
100% agree
 
1 - 19 of 19 Posts
Top